Mikrotik отправка логов на почту

Mikrotik отправка логов на почту

Полезно

— Узнать IP — адрес компьютера в интернете

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Калькулятор инсталляции IP — АТС Asterisk

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Навигация

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

Популярное и похожее

Настройка PPTP клиента на Mikrotik

Мониторим MikroTik с помощью Zabbix по SNMP

Настройка PPTP клиента на Mikrotik

Настройка L2TP сервера на Mikrotik

Настройка отправки email с MikroTik

3 минуты чтения

Рассказываем про ещё один полезный инструмент на роутерах MikroTik — отправку e-mail сообщений по протоколу SMTP. Данный инструмент может быть использован для отправки на почту периодических бэкапов или же задействован для написания каких-нибудь скриптов.

  • В интерфейсе WinBox, утилита Email расположена в разделе ToolsEmail:

  • Из командной строки — /tool e-mail .

Первым делом нужно настроить сервер исходящей почты по протоколу SMTP. Доступны следующие параметры настройки:

  • address — IPv4/v6 адрес, SMTP сервера;
  • from — имя или название почтового ящика, который будет показан получателю;
  • password — пароль, который используется для аутентификации на SMTP сервере. В этом случае аутентификации не будет шифроваться. Для включения шифрования можно использовать функцию start-tls;
  • port — порт SMTP сервера, по умолчанию 25;
  • start-tls — может принимать значения no, yes и tls-only — разрешает только TLS шифрования без поддержки SSL;
  • user — имя пользователя, которое будет использоваться для аутентификации на SMTP сервере.

Когда сервер будет настроен, можно начинать отправлять письма. Все параметры при отправке писем идут после команды /tool e-mail send:

  • body — тело письма
  • cc — данный параметр позволяет поставить в копию дополнительных получателей;
  • file — позволяет добавлять один или несколько файлов во вложении к письму;
  • from — название или почтовый адрес, который будет показан как отправитель. Если ничего не указано, то будет взят from, который указывался при настройке сервера SMTP;
  • password — пароль, который используется для аутентификации на SMTP сервере. Если ничего не указано, то будет взят password, который указывался при настройке сервера SMTP;
  • port — порт SMTP сервера. Если ничего не указано, то будет взят port, который указывался при настройке сервера;
  • server — адрес SMTP сервера. Если не указано, то используется параметр сервера, указанный при настройке;
  • start-tls — использовать ли TLS шифрование;
  • subject — тема письма;
  • to — адрес получателя, которому предназначено письмо;
  • user — имя пользователя, для аутентификации на сервере. Если не указано, то будет использоваться user из настроек сервера.
Читайте также:  Чем отличается зенфон от смартфона

Теперь давайте применим механизм отправки писем на практике и создадим скрипт, который будет каждый день высылать файл с резервной копией конфигурации нам на почту.

Вот как настройка будет выглядеть в командной строке:

Теперь добавим новый скрипт, который будет делать бэкап конфигурации роутера:

Добавим скрипт на выгрузку конфигурации в планировщик:

Готово, теперь каждый день нам на почту mnadmin@mndomain.ru будет приходить свежая выгрузка резервной копии конфигурации нашего роутера.

Для того, чтобы настроить отправку писем на почтовый ящик, требующий TLS шифрования (как например Google mail), нужно настроить следующие параметры отправителя:

При отправке письма на такой ящик, необходимо указать параметр start-tls.

Если Вы предпочитаете настраивать роутер с помощью интерфейса WinBox, то откройте ToolsEmail и настройте параметры сервера:

Далее заходим в SystemScripts и добавляем новый скрипт на выгрузку конфигурации:

Добавляем скрипт в планировщик, чтобы он срабатывал каждый день:

Пожалуйста, расскажите почему?

Нам жаль, что статья не была полезна для вас 🙁 Пожалуйста, если не затруднит, укажите по какой причине? Мы будем очень благодарны за подробный ответ. Спасибо, что помогаете нам стать лучше!

Подпишитесь на нашу еженедельную рассылку, и мы будем присылать самые интересные публикации 🙂 Просто оставьте свои данные в форме ниже.

воскресенье, 7 октября 2012 г.

Mikrotik RouterOS log/backup to email

Хочу поделиться своим "вылизанным" скриптом бэкапа конфигурации и отсылки логов на почту с Mikrotik RouterBoard RB750GL (в моём случае 5.14, firmware 2.38). Думаю подойдёт к большинству устройств на этой славной ОС. Преимущество подхода в том, что сам файл конфигурации приходит в качестве приложенного к письму с логами файла. А логи находятся прямо в письме — не в приложении.

#:log info "///—-> Я начал бэкапиться" (расскоменчиваю эти строки для дебага)
:global backupfile ([/system identity get name] . ".backup") #задаю переменную
:if ([/file find name=$backupfile] != "") do= #удаляю, если файл уже существует
:delay 2s

#:log info "///—-> Подготавливаю лог для отправки"

Читайте также:  Помогу чем смогу запятые

:global logMessages;
:set logMessages ""
:foreach i in=[/log find ] do= <
:set logMessages ($logMessages . [/log get $i time ] . " ");
:set logMessages ($logMessages . [/log get $i message ]);
:set logMessages ($logMessages . "
")
>

#:log info "///—-> Создаю бэкап"
/system backup save name=$backupfile
#:log info "///—-> Жду 5 сек. завершения процедуры"
:delay 5s
#:log info "///—-> Посылаю конфиг на e-mail" (следующий код — одна длинная строка!)
/tool e-mail send to=mail@examle.com subject=("router daily backup") file=$backupfile body=("Бэкап конфигурационного файла маршрутизатора " . [/system identity get name] . ".
Выполнен: " . [/system clock get time] . " " . [/system clock get date] . "
____________________

Uptime: " . [/system resource get uptime] . "
Свободно оперативки: " . [/system resource get free-memory] . " из " . [/system resource get total-memory] . " Кбайт.
Свободное место: " . [/system resource get free-hdd-space] . " из " . [/system resource get total-hdd-space] . " Кбайт.
Bad-блоки: " . [/system resource get bad-blocks] . " %.
Загрузка процессора на данный момент: " . [/system resource get cpu-load] . " %
____________________

Последние записи в логе:

" . $logMessages . "
____________________
" . [/system identity get name])
#:log info "///—-> Жду 10 сек. пока письмо отправится"
:delay 10s
/file remove $backupfile
:log info "///—-> Бэкап завершён. Файл послан на mail@example.com. Ура!"

Ставлю на еженощное выполнение и в результате вместе с новостями с утра читаю вести с фронта — на почту приходит письмо такого вида

Имею Mikrotik RouterBoard RB750GL, RouterOS 5.7.
Хочу послать содержимое его лога в теле письма. В консоли пишу

/tool e-mail send to=example@example.com subject=("log") body=([/log print])

В результате весь лог вываливается в консоль, а на почту приходит пустое письмо. ЧЯДНТ?

Ссылка на основную публикацию
K pl oa1 уменьшить ток подсветки
Внимание! Информация предназначена для технически подготовленных специалистов! Владельцам и пользователям телевизоров следует помнить, неквалифицированное вмешательство может в дальнейшем существенно повысить...
Global c state control ryzen что это
Украинский энтузиаст Юрий «1usmus» Бублий хорошо известен в компьютерном сообществе далеко за пределами нашей страны благодаря собственным исследованиям «железа» AMD....
Hyundai h ms1113 как включить usb
25 страниц подробных инструкций и пользовательских руководств по эксплуатации Содержание: Содержание. Музыкальные центры Hyundai Меры техники безопасности. 27 Назначение и...
Meendo как удалить аккаунт
RPI.su - самая большая русскоязычная база вопросов и ответов. Наш проект был реализован как продолжение популярного сервиса otvety.google.ru, который был...
Adblock detector